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Disclaimer and Software License Agreement 
Before you use Personal Stock Streamer (the ''Software'') for the first time, please read this Disclaimer and 
License Agreement.  By your action of using Personal Stock Streamer, you are agreeing to comply with all 
terms contained in this License. 
 
Users of Personal Stock Streamer must accept this disclaimer of warranty: ''The Software is supplied AS 
IS.  DTLink, LLC (''DTLink'') disclaims all warranties, expressed or implied, including, without limitation, 
the warranties of merchantability and of fitness for any purpose.  DTLink assumes no liability for damages, 
direct or consequential, which may result from the use of the Software.'' 
 
The Software is provided at no charge to the user.  The user is responsible for maintaining a subscription in 
good standing with one of the data services supported in this software.  The costs associated with 
maintaining the subscription are the sole responsibility of the user. 
 
PERSONAL STOCK STREAMER IS DESIGNED TO DISPLAY STOCK PRICE DATA FOR THE 
END-USER.  THE END-USER IS SOLELY RESPONSIBLE FOR THE ACQUISITION OF STOCK 
PRICE DATA FROM THIRD-PARTY SOURCES.  DT LINK HEREBY DISCLAIMS ANY AND ALL 
RESPONSIBILITY OR LIABILITY REGARDING THE ACQUISITION, AVAILABILITY, OR 
ACCURACY OF STOCK PRICE DATA FOR USE WITH THE LICENSED PRODUCT. 
 
Individuals may freely distribute only unaltered copies of the archive containing the Software and all 
associated files only to other individuals. Organizations who wish to include this program in distributions 
or bundles for remuneration must contact DTLink for explicit authorization. 
 
The Title, ownership rights, and intellectual property rights in and to the Software shall remain with 
DTLink.  You agree to abide by the copyright law and all other applicable laws of the United States 
including, but not limited to, export control laws.  You acknowledge that the Software in source code form 
remains a confidential trade secret of DTLink therefore you agree not to modify the Software or attempt to 
decipher, decompile, disassemble or reverse engineer the Software, except to the extent applicable laws 
specifically prohibit such restriction. 
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1. Introduction 

About Personal Stock Streamer 
Thank you for choosing Personal Stock Streamer, the desktop companion for informed investors.  Personal 
Stock Streamer is based on the award-winning Personal Stock Streamer software which was first released 
in April 1996.  Personal Stock Monitor has become one of the premier investment tracking and portfolio 
management applications, and Personal Stock Streamer builds on that reputation to improve your investing 
experience even further.  Our customers include everyone from first-time investors to people managing 
multi-million dollar portfolios, and the software helps them all keep better track of their investments and 
make timely and informed decisions. 

System Requirements 
Minimum requirements: 
• Windows 98, ME, 2000, XP, 2003, or later 
• Pentium-class processor 
• 64MB RAM 
• 800x600 video 
• 10MB hard drive space 
• Dial-up internet connection 
 
Recommended: 
• Pentium 4-class processor 
• 256 MB RAM 
• 20 MB free disk space 
• High-speed internet connection 
 
2. Installation 
 
To install Personal Stock Streamer simply double-click on the distribution file.  This file should be called 
something like StockStreamer70.exe (for version 7.0) if you downloaded it from a web site.  Running this 
file will start the installation wizard, which will guide you through the process of installing the software on 
your computer. 
 
During installation you will be presented with a series of options.  If you are installing Personal Stock 
Streamer for the first time or are unsure about what to do, you should accept the default options.  Personal 
Stock Streamer is designed to be upgraded in-place, so if you are upgrading from a previous release the 
installation program will attempt to install it in the same directory as the previous installation and will make 
this the default option.  In most cases you will want to accept these options as-is.  Since some releases of 
the software will update the format of your data files, we recommend backing up your data files regularly 
and especially before installing upgrades. 

Note for Personal Stock Monitor Users 
 
Personal Stock Streamer may be installed on the same machine as Personal Stock Monitor without 
affecting the Personal Stock Monitor installation.  By default it installs into a different folder on your hard 
drive and uses a different location for configuration information, so program preferences you have set in 
Personal Stock Monitor will need to be re-set in Personal Stock Streamer. 

QuickStart 
  
The first time you run Personal Stock Streamer, it will automatically run a utility we call the QuickStart 
Wizard.  This wizard will guide you through the initial steps in setting up Personal Stock Streamer for your 

 5



Internet connection.  If you have a recent version of Internet Explorer, Firefox, or Netscape already 
working on your system, Personal Stock Streamer may be able to automatically configure itself by copying 
the Internet settings from one of those browsers. 

Selecting Your Internet Connection 
Personal Stock Streamer supports connections through Dial-Up Networking as well as direct connections 
(such as DSL, cable modem, DirectPC, LAN, etc.). The QuickStart Wizard will allow you to select the 
connection type that the software will use for retrieving quotes. 
 
If you use a dial-up connection through a regular phone modem, or you have an internal ISDN modem that 
requires you to start Dial-Up Networking to connect to your Internet Service Provider (ISP), then you will 
want to configure Personal Stock Streamer to use the dial-up connection.  In the case of AOL or 
CompuServe connections, their network access software is not compatible with the general method of 
using Dial-Up Networking.  If you are using one of those networks you will need to disable the dial-up 
option in Personal Stock Streamer and manually dial into those networks before attempting to retrieve 
quotes.  (Selecting the AOL option in the QuickStart Wizrad will automatically do this for you.) 
 
If you have direct connection such as DSL or cable modem, or you are on the office network (LAN) or 
similar network, you should make sure that the dial-up settings are disabled.  When dial-up settings are 
disabled, Personal Stock Streamer assumes a direct connection and will not attempt to dial out.  This is also 
important in the case where you start out with a modem connection then get a DSL or cable modem at your 
house.  Just disable the dial-up option and Personal Stock Streamer should then work with your new faster 
connection. 
 
• To change the dial-up settings (outside of the QuickStart Wizard), select Options->Preferences->Dial-

Up. 

Proxy Configuration 
 
The trickiest part of the initial installation is often the "proxy" configuration.  A proxy, sometimes also 
known as a "proxy server" or "firewall", is a computer or device that sits on your network between your 
computer and the Internet (Figure 1).  It is known as a proxy because it communicates with the outside 
world on your behalf, and in such a position can implement access control and security policies of the 
organization, allowing you to hide computers from direct access by people on the Internet. 
 

Your Computer Proxy or Firewall

The
Internet

If you have a direct dial-up connection, cable modem, DSL, or other type of direct connection, you 
probably do not need to worry about proxy configuration and can leave it turned off.  If you are in a 
corporate setting with a proxy or firewall, Personal Stock Streamer may be able to figure out the correct 
configuration if your web browser uses "manual proxy configuration".  If your browser uses "automatic 
proxy configuration," Personal Stock Streamer will not be able to determine the proxy settings by itself. 

Figure 1 - Hypothetical network with proxy server 

In the case where the proxy configuration can not be automatically determined, there is one bit of technical 
information you will need to have: the host name or Internet Protocol (IP) address of the proxy host, and 
the port to use for the web proxy.  The host name is often something like "proxy.yourcompany.com", and 
the port number is often something like "80", "8000", or "8080".  If you are not sure what the proxy settings 
should be, please ask your network administrator for this information.  When you find out these settings, 
enter them into the proxy settings dialog in the Quick Start 3Wizard or in the Options->Preferences->Proxy 
dialog. 

 6



 
After you enter the network settings, the Quick Start Wizard will give you the option of running a basic test 
to see if Personal Stock Streamer can retrieve Web pages from some sites on the Internet.  We recommend 
running this test before proceeding, because a failed test here could indicate that Personal Stock Streamer 
will not be able to retrieve quotes. 

Software Upgrades 
 
Personal Stock Streamer is updated fairly often because we are constantly working on improving it as well 
as correcting any problems found in previous releases. 
 
In order to provide better service for our customers, we have created two features that help you determine 
when an upgrade is available and what changes were made.  First, there is a Personal Stock Streamer News 
feature that alerts you to any news or updates that may be available.  When Personal Stock Streamer first 
goes online, it automatically checks for any news and updates.  If news or updates are found, a yellow 
scrolling message containing a brief synopsis of the news will appear in the status bar of the Personal Stock 
Streamer window.  You can bring up the detailed information by clicking on the yellow the message.  
While this feature is normally run automatically, you can also run it manually from the Online menu. 
  
Second, Personal Stock Streamer includes a tool called the Software Update Wizard that can check the 
software database on our Web server.  The Software Update Wizard can then download the updates and 
install them immediately.  You can run the Software Update Wizard at any time from the Help menu.  If for 
some reason the Software Update Wizard fails to properly download a release, you can always download 
the exact same software from the DTLink web site and install it manually. 
 
Personal Stock Streamer is designed to be upgraded in-place, which means that you can simply install any 
new versions into the same directory as the old version.  All program and license settings will be retained 
from the previous version, but we still recommend making backups between versions "just in case". 
 
  
3. Basic Concepts 
This section describes many of the terms and concepts used throughout the software and the rest of this 
User's Guide. 

The Tour Guide 
The Tour Guide is designed to demonstrate just a few of the most frequently used features in Personal 
Stock Streamer.  When you first run Personal Stock Streamer, the Tour Guide will appear in a window to 
the left of the main workspace.  You can also display the Tour Guide by selecting the Tour Guide 
command from the Help menu. 
 
Simply follow the directions in the tour guide to become familiar with the common functions available in 
Personal Stock Streamer. 

QuickLinks 
The QuickLinks in Personal Stock Streamer is kind of like Windows shortcuts: it provides a way to quickly 
perform a number of the common tasks in Personal Stock Streamer without having to look for the right 
command in the menus.  QuickLinks will appear after the Tour Guide is completed, or you can select the 
QuickLinks command from the Help menu. 

Online Help 
Context-sensitive online help is available throughout the application.  To bring up the online help, press the 
F1 key or the Help button if available in a particular dialog.  You can also select Help Topics from the Help 
menu to browse the help file.  
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.stkx Files 
Personal Stock Streamer stores all of your portfolio data and transactions (as well as things like column and 
view settings) in files on your hard drive that have an ".stkx" file extension.  The software even includes 
two such sample files called Dow30.stkx and Sample Portfolio.stkx for demonstration purposes.  These two 
files should not be used to store your personal portfolio data because they may be overwritten during a 
software upgrade if you're not careful.  Instead you should create a new file for your personal use and make 
regular backups so that you are protected against any unforeseen events such as hard disk crashes. 
 

Note for Personal Stock Monitor Users: Personal Stock Monitor uses the .stk file extension for 
its data files, which are not compatible with .stkx files.  Personal Stock Streamer can read .stk files 
and will convert them to .stkx files, but Personal Stock Monitor can not read .stkx files. 

Bookmarks 
Personal Stock Streamer provides a flexible Internet bookmarks facility which allows you to store 
frequently used links to web sites with the software.  In addition, bookmarks can easily be dragged from a 
web browser and dropped in to Personal Stock Streamer. 
 
There are three types of bookmarks: regular bookmarks, Jump Points, and Ticker Bookmarks.  The regular 
bookmarks function just like the bookmarks or favorites in your web browser in that they are available at 
any time.  Jump Points are special bookmarks that allow you to substitute the ticker symbol or ticker name 
as part of the bookmark.  This allows you to create bookmarks for things like discussion boards or research 
and have them automatically apply to all of your stocks.  Ticker Bookmarks are what we call "local" 
bookmarks, in that they are stored with a ticker symbol and can be used to save things like links to specific 
articles about the particular ticker.  More on bookmarks a little bit later. 

Ticker Symbols 
Each type of security (stock, mutual fund, option, etc.) is represented by a 
ticker symbol, which is often shorthand for the name of the security.  
Ticker symbols are used by financial services to display information about 
that security in a more compact way than writing out the entire name.   For 
example, the ticker symbol for At Home Corporation is ATHM, for 
America Online it is AOL, and for the Fidelity Magellan mutual fund it is 
FMAGX. 
 
Although the actual long name of the security is available for display 
purposes, Personal Stock Streamer uses ticker symbols as the main method 
of identifying securities.  If you do not know the ticker symbol for a particular security, you can use the 
Find Ticker Symbol function (under the Symbol menu) to look it up. 

Figure 2 - Associating 
ticker symbols with 

company names 

Cash Symbols 
You can also create a special type of ticker symbol to represent the uninvested balance in your account.  
This is called a cash symbol because it represents a cash or money market balance.  You can create a 
linked cash symbol which will be updated automatically by Personal Stock Streamer based on transactions 
posted directly to the cash symbol (such as deposit and interest) and transactions posted to ticker symbols 
in the same account (such as buy and sell).  There can be only one linked cash symbol in an account.  You 
can also create unlinked (or "Other") cash symbols to represent things such as a Certificate of Deposit 
(CD), and these will only be updated from transactions posted to the cash symbol.  There are no limits on 
the number of unlinked cash symbols you can create. 

Transactions 
Transactions (buy, sell, dividend, etc.) are the method used by Personal Stock Streamer to keep track of 
your current holdings, and based on that information to automatically calculate current value, change in 
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value, and realized and unrealized gain.  Having a complete transaction history for all investments entered 
into Personal Stock Streamer is an essential step to having a complete picture of your portfolio. 
 
After you execute a trade with your broker, you should enter the information into Personal Stock Streamer 
as a new transaction.  The software will calculate any gain, automatically adjust your uninvested funds 
balance to reflect the trade, and recalculate the current value of the investment based on that trade.  You get 
immediate feedback on the effects of your trade without having to run separate reports. 

Since Personal Stock Streamer makes it easy to edit or delete transactions, this feature is also useful for 
playing "what-if" with your investments. You can enter test transactions to see how your portfolio would 
change based on a trade or sequence of trades and see the results immediately reflected in all views. 

Figure 3 - Example of transactions in the Transactions view 

 
One important thing to keep in mind is that transactions are intimately linked to their ticker symbols, and 
therefore many of the things you do to ticker symbols will have an effect on the transactions that are posted 
to that ticker symbol.  For example, if you move a ticker symbol from one folder to another, any 
transactions that have been posted to that ticker symbol will move as well, or if you delete a ticker symbol 
the transactions would be deleted as well. As mentioned in the previous section, linked cash symbols are 
calculated partly from transactions posted to ticker symbols so doing something like moving or deleting a 
ticker symbol will affect the balance of related linked cash symbols.  It is therefore very important to 
remember these relationships when you are working with ticker symbols and transactions. 

Portfolios 
Portfolios are the method used to group folders, accounts, ticker symbols, and transactions into one "view" 
(more on views later).  Portfolios may represent anything from a person's actual accounts to a group of 
stocks you are watching for an experimental investment strategy. 
 
In Personal Stock Streamer you can create an unlimited number of portfolios, each of which is represented 
by a tab at the bottom of the main window.  Changing the portfolio is as easy as clicking on the 
corresponding tab.  You can even change the order of the portfolio tabs by dragging and dropping tabs into 
place! 

Figure 4 - Multiple portfolio tabs 

Folders and Accounts 
Folders and accounts are used in Personal Stock Streamer to group related ticker 
symbols together.  Essentially folders and accounts are the same thing as far as 
Personal Stock Streamer is concerned, and we use the terms interchangeably.  
We will use the term account when a group of ticker symbols represents an 
actual account at a financial institution, such as a brokerage account.  Accounts 
will usually have a cash symbol inside of them to represent the 
uninvested balance of the account.  We will use the term folder when a 
group of ticker symbols do not necessarily belong in a brokerage account, 
but may be related by industry or other common feature.  An example of 
this would be an Internet folder, which contained only Internet stocks. 

Figure 5 - An 
example Internet 

folder 
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Quote Servers 
Personal Stock Streamer uses the concept of a quote server to represent a location or company that 
provides quotes or news headlines.  Personal Stock Streamer includes support for several streaming quote 
services.  Most if not all of these quote services offer free trials which will allow you to determine which 
quote service is best suited for your needs. 

Delayed vs. Real-time, Snapshot vs. Streaming 
Different investing styles have different requirements for quotes, so data providers have created quote 
servers that provide different types of quotes.  There are two types of quotes, real-time and delayed, and 
two ways to deliver those quotes, snapshot and streaming.  The combination of these factors may influence 
your choice of data provider and the price you pay for your service. 
 
Delayed quotes represent trades that happened some number of minutes before you retrieved the quote, 
usually 15-20.  For example, if you get a delayed quote at 12:30 from a 15-minute delayed quote server, the 
quote you get will be from a trade that happened at 12:15 or before.  The reason delayed quotes are often 
provided for free is that they are less relevant for making quick trades, since activities such as day trading 
rely on having the absolute latest prices.  However delayed quotes are still useful for following your 
investments over time and therefore should be adequate for the majority of investors. 
 
Real-time quotes represent trades that happened exactly at the time of the quote, so the numbers you get at 
noon are from the last trade that happened at noon or immediately before the time of the quote. 
 
Snapshot quotes are like taking a picture: you get a quote that is exactly what the last trade looked like at 
the point the trade happened.  In order to get quotes over time, you have to keep taking pictures at regular 
intervals even if no additional trades happened during that time.  
 
Streaming quotes are like watching a movie.  The pictures are displayed for you in rapid succession and all 
you have to do is sit back and watch.  Similarly, with streaming quotes you automatically get sent 
information about each trade as it happens (or 15-20 minutes delayed if you are getting streaming delayed 
quotes).  This method is more efficient than repeatedly getting snapshot quotes, but it also generally more 
expensive because of the timeliness of the data. 
 
Personal Stock Streamer supports data services which provide streaming quotes.  Most of the quote 
services provide streaming real-time quotes, but some may also offer a delayed option at a lower cost. 

Free vs. Subscription Quotes 
Personal Stock Streamer only supports subscription quote services.  It includes links to information and 
subscription pages for all of the supported quote services so that you can make an informed decision as to 
which service to order. 
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4. Using Personal Stock Streamer 

The Main Window 
First let's go over the various parts of the main window.  Familiarizing yourself with the layout of the 
software will help you to perform the various tasks even faster. 
 

Info Bar 

Menu Bar 

Main 
Workspace 

Toolbar 

View Selection Tabs 

Streaming 
Indicator 

Portfolio Tab Status Bar 

Figure 6 The Main Window 

The menu bar contains all of the commands and options that are available in Personal Stock Streamer, 
roughly organized by category.  The toolbars contain what are essentially shortcuts to the most commonly 
used commands that are also available in the menu bar.  The info bar is where the Tour Guide and 
QuickLinks are displayed.  The main workspace is where all of your folders and ticker symbols will be 
displayed.  A portfolio tab represents each portfolio in the current file and allows you to easily switch 
between portfolios by clicking on the desired tab.  The status bar displays status messages such as when 
data is being received or when a minor error occurs.  The streaming indicator shows the state of the 
current connection; it will show “streaming” when streaming is active, or it will indicate when quote 
updates are suspended or turned off.  Immediately to the left of the streaming indicator there is a news 
indicator (not visible in the screen shot above) that will indicate where there are unread articles available.  
When the indicator appears, you can click on it to read the news. 
 
We saved the final item in the screen shot for last because it is special. The view selection tabs allow you 
to easily switch between the various "views" in Personal Stock Streamer: the Active Securities view, the 
Holdings view, the Transactions view, and the Reports view.  More on views a bit later, but keep these tabs 
in mind because you may be using them frequently. 

Menus and Toolbars 
The menu bar at the top of the window (File, Edit, etc.) is used to access all of the Personal Stock Streamer 
functions and commands.  Each menu is organized as follows according to the functions contained under it. 
 
• File - Commands that work with entire files, including New, Open, Save, Import, Export, and Print. 
• Edit - Commands that work on symbols in the current file, including Copy, Paste, and Find. 
• Online - Commands that are related to Personal Stock Streamer's use of the Internet. 
• Portfolio - Commands that are related to portfolios, ticker symbols or folders, including New Portfolio, 

Find Ticker Symbol, Clear Alert, Enter Transaction, and Chart. 
• View - Commands related to the view, including Sort, Layout, Portfolio Details, and Ticker Bar. 
• Options - Program options and settings. 
• Tools – Extensions and additional tools. 
• Help - Online help and information. 
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Some menu items have associated icons that are displayed next to the item.  These icons are the same as the 
icons displayed in the Toolbars, so instead of going through the menus to select a function, you can click 
the appropriate toolbar icon to perform the same task.  Therefore toolbars simply become a shortcut to 
using the menus. 
 
Many of the most common menu commands also have keyboard shortcuts, which are special key 
combinations that execute the related command.  If a keyboard shortcut is defined for a menu item, the key 
combination is displayed next to that menu item.  For example, the shortcut for the Find Ticker Symbol 
command under the Portfolio menu is Alt+L.  This means that if you press the Alt key and L key at the 
same time, Personal Stock Streamer will execute the Find Ticker Symbol command just like if you used the 
mouse to select it from the menu. 

Figure 7 - Menu command with icon and keyboard shortcut 

Right-Click Menus 
Personal Stock Streamer uses many "right-click menus" (also known as context menus) which are pop-up 
menus that appear next to the mouse cursor when you click the right mouse button or press the context 
menu key on your keyboard.  The exact menu that is displayed can vary depending on where your mouse 
cursor is at the time you click the button, which is why these types of menus are often referred to as 
"context-sensitive".  Context menus are intended to be a quick way of accessing commonly used menu 
commands or extended functionality. 

Working with .stkx Files 
When you first start using Personal Stock Streamer, you should create a new file to store your portfolio 
data.  Using the Dow30.stkx or Sample Portfolio.stkx files included with Personal Stock Streamer is not 
recommended because when you upgrade the software they may be overwritten by the installer. 
 
• To create a new .stkx file, select File->New. 
• To open an existing .stkx file, select File->Open. 
• Several of the most recently used files will be listed at the bottom of the File menu.  You can switch 

between them easily by selecting the appropriate menu item. 
 

Note for Personal Stock Monitor Users: Personal Stock Monitor uses the .stk file extension for 
its data files, which are not compatible with .stkx files.  Personal Stock Streamer can open .stk 
files and will convert them to .stkx files, but Personal Stock Monitor can not open .stkx files. 

Workspace Views 
There are several different "views" in Personal Stock Streamer which help you see different parts of your 
data in different ways.  The built-in views include Active Securities, Current Holdings, Transactions, and 
Reports, and additional views may be created through software extensions known as plug-ins. You can 
switch between the views using the view selection tabs above the main workspace or by selecting the 
appropriate item under the View menu. 
  
What is in the different views?  The Active Securities view is probably the view you will be looking at 
most of the time. In this view you create folders and portfolios, and add ticker symbols to fill in those 
portfolios and watch lists.  This view contains only active ticker symbols and folders, which are those that 
you are currently watching and/or updating.  To remove a ticker symbol from this view you must either 
mark it inactive or delete it from the document, both of which will be described later. 
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The Current Holdings view displays only the ticker symbols in which you have an open position, and it 
breaks out current holdings by lot.  This view is useful as a portfolio summary view for your current 
holdings. 
 
The Transactions view shows your complete trading history broken out into individual transactions.  The 
transaction records are used to calculate current holdings as well as realized and unrealized gains, and will 
be used in future versions of Personal Stock Streamer in order to produce reports. 
 
The Reports view displays any reports generated from the current portfolio data.  Available reports include 
a capital gains summary, transaction detail, and value by asset class*. 

How the Views are Related 
Imagine a single building that has many windows.  Looking in any one of the windows allows you to see a 
different part of the building or a different perspective, but it is still the same building.  In a similar way, 
the workspace views just give you a different perspective of your document, but it is still the same 
document and the same data. 
 
Consider a ticker symbol that has one purchase transaction but no sale transaction.  This ticker symbol is 
said to have an open position.  The symbol would be displayed in the Active Securities view because it is 
an active ticker and in the Current Holdings view because it has an open position.  It would also be 
displayed in the Transactions view because there is one transaction posted to it. 
 
This concept is extremely important when you consider how ticker symbols can be changed.  Since 
transactions are directly linked to their ticker symbols, if you moved a ticker symbol from one folder to 
another the transactions would move as well, and this change would be reflected in the Holdings and 
Transactions views. 

Customizing the Views 
Personal Stock Streamer gathers a lot of data, and there are several options available that can make it easier 
to manage the flood and make it easier to read.  By default, Personal Stock Streamer enables alternating 
color bars in the main workspace, which makes reading across the window easier.  The default color here is 
gray, but you can easily change that in the preferences.  There is also an option to display grid lines, which 
can help reading up and across the window.  You can even set the background color on individual ticker 
symbols to "color-code" different types of symbols and make them easier to find in a long list.  But the best 
customization feature allows you to change which columns are displayed on the screen so you only see the 
columns you want. 
 
Although by default you are shown several columns on 
the screen, this is only a subset of the information that is 
available.  We just didn't want to overload you with 
information right away, because Personal Stock Streamer 
can display dozens of columns of information!  The views 
are completely configurable using the Arrange Columns 
command or the equivalent button on the toolbar, which 
will bring up a dialog in which you can select which 
columns appear on the screen as well as the order in 
which they appear. 

Figure 8 The Arrange Columns dialog 

 
• To enable grid lines or alternating color bars or to 

change the color of the bars, select Options-
>Preferences->Display. 

• To set the background color on ticker symbols, select 
the symbols, then select Portfolio->Ticker 
Properties->Advanced. 

• To select which columns are displayed, select View->Layout->Arrange Columns. 
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View Layouts 
As you can see in Figure 8, there are many columns to choose from, which allows you to select just the 
information that you are interested in.  Even better, you are not limited to just one column configuration.  
Personal Stock Streamer includes a feature which lets you create named groups of column configurations 
called view layouts.  Using the Edit All Layouts command under the View menu, you can create multiple 
view layouts, each with a different column configuration. A view layout can be selected into any portfolio 
in your file, and if you switch away from that portfolio it will automatically switch back to that view layout 
when you come back. 
 
Using a toolbar button you can easily switch between your view layouts to quickly see different sets of 
columns.  This allows you to concentrate on the columns you want to see most, but quickly view other 
columns when necessary. 
 
• To create or edit view layouts, select View->Layout->Edit All Layouts. 
• To change to a different view layout, select the layout by name from the View->Layout menu. 

Custom Columns 
Starting with Personal Stock Streamer 7.1, you can create custom memo or expression columns. 
 
Memo columns are simple columns that can contain comments or other information.  You can edit the 
content of memo columns by first highlighting the ticker, then clicking in the memo column.  This will 
display an edit box which will allow you to type in the information. 
 
Expression columns calculate their value using a mathematical expression.  You can not directly edit the 
content of these columns except to edit the mathematical expression that calculates the value. 
 
• To create or edit custom columns, select Options->Preferences->Custom Columns. 
 
• For expression columns, the field names in the expression must be exactly the same as the names on 

the columns, including capitalization, and they must be entered in quotes.  For example, if you want to 
use the Price field in an expression, you must enter it as “Price”, because “price” will not work.  The 
only exception is field with spaces, in which case the spaces are optional so for example “% Change” 
can also be entered as “%Change” and “52 Week High” can also be entered as “52WeekHigh”. 

 
The following are valid operators and types for expressions: 
 

Operator Description 
<, >, <=, >=, == Standard comparison operators: less than, greater than, 

less than or equals, greater than or equals, exactly 
equals. 

&&, || Boolean AND and OR operators 
(, ) Paretheses are used to control order of evaluation by 

creating sub-expressions. 
abs() Function that returns the absolute value of its argument 
+, -, /, * Standard mathematical operators: add, subtract, divide, 

multiply. 
 
• For example, you can create an expression column that displays the difference between the current 

high value and price: High – Price 
 
When you create custom columns, they are added to the available columns in the Active Securities and 
Current Holdings views, but they are not automatically visible.  You will need to use the View->Layout-
>Arrange Columns command to show your custom columns. 
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Multiple Portfolios 
With Personal Stock Streamer you can create multiple portfolios in a single document and easily switch 
between them.  This is very useful if you have accounts at different brokerages, or if you are managing 
portfolios for other people.  Summary data such as totals are calculated separately for each portfolio so you 
will know exactly how each portfolio is doing. 
 
A tab at the bottom of the main window represents each portfolio in the current document.  The tab 
representing the currently displayed portfolio has a white background, while all others have a gray 
background. 
 
• To create a new portfolio, select Portfolio->New Portfolio. 
• To rename the current portfolio, select Portfolio->Rename Portfolio. 
• To view a different portfolio, click on its tab at the bottom of the main window. 
• You can switch between the first ten portfolios in your document by pressing the Alt key and a number 

key.  For example, pressing Alt+1 will switch you to the first portfolio, and pressing Alt+0 will switch 
you to the tenth portfolio. 

• You can rearrange portfolios by using your mouse to drag the portfolio tab to the desired location in 
the list. 

Portfolio Properties 
Each portfolio can have its own currency, quote server, and update settings.  For example you may wish to 
have a portfolio whose ticker symbols are never updated, or updated only from a particular quote server, 
displayed in a different currency than the other portfolios. 
 
• To edit portfolio settings, including currency and update settings, select Portfolio->Portfolio 

Properties. 

Portfolio Alerts 
Personal Stock Streamer has an additional option in the Portfolio Properties dialog that allows you to set 
alerts for entire portfolios that are applied to all tickers contained inside the portfolio.  The details of setting 
alerts are described later in this document. 

Working with Folders 
Each portfolio can contain just ticker symbols if you like, but you can also create folders to group ticker 
symbols together. You can create any number of folders to group your ticker symbols into categories.  For 
example, you can create an Internet folder for all of your Internet stocks, or a Retail folder for all retail 
stocks.  This will help you see the performance of any group very quickly. In the Sample Portfolio.stk file 
that is included with Personal Stock Streamer, there are several such folders, each for different types of 
stocks such as Internet, e-commerce, and so on.  Similarly, you can create folders in your own portfolios to 
group stocks for organizational purposes.  Folders can also be created inside other folders, so you can have 
as many levels of folders as you need. 
 
• To create a folder, select Portfolio->New->Folder/Account. 
• To collapse or expand a folder, double-click on it, or right-click and select Collapse or Expand. 
• To create a ticker symbol or a folder inside a given folder, first select the folder then select the new 

ticker symbol command (see below) or new folder command. 
• To move a ticker symbol into or out of a folder, select the ticker symbol and drag it to the desired 

location. 
• To move a ticker symbol under a folder without placing it into the folder (using drag and drop), hold 

down the control key when dropping the symbol into its place. 
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Folder Properties 
Each folder can also have its own update and quote server settings similar to the options available for 
portfolios.  That is to say that you can set individual folders to update from different quote servers or at 
different intervals. 
 
• To change the update settings for a folder, select Portfolio->Folder Properties. 

Folder Alerts 
Personal Stock Streamer has an additional option in the Folder Properties dialog that allows you to set 
alerts for the entire folder.  These alerts are valid for all sub-folders and ticker symbols contained in the 
folder.  The details regarding setting up folder alerts are described later in this document. 

Working with Ticker Symbols 
Ticker symbols are used to represent the security itself to the quote server.  Personal Stock Streamer also 
uses ticker symbols to stock your transactions, alerts, historical data, and view settings related to the 
security. 
 
• To create a new ticker symbol, select Portfolio->New->Ticker Symbol. 
 
When manually entering ticker symbols it is important to remember to set the ticker type properly because 
some quote servers require special handling for certain ticker types in order to properly retrieve quotes. The 
default ticker type is Stock, but if you are tracking mutual funds, options, or other types of tickers you 
should make sure to change this option appropriately.  If you forget to set the ticker type while creating the 
symbol you can still change it using the ticker properties dialog. 

Ticker Properties 
The ticker symbol properties dialog allows you to change various settings that are specific to the ticker 
symbol.  You can use this dialog to set the ticker type, assign asset classes, set alerts, enter or edit 
transactions, enter notes, override global settings, and perform other operations related to the ticker symbol. 
 
• To display the ticker symbol properties dialog, select the ticker symbol then select Portfolio->Ticker 

Properties. 

Finding Ticker Symbols 
One thing to keep in mind is that each quote server has its particular requirements for ticker symbols.  
Since most quote servers accept symbols in all capital letters, Personal Stock Streamer by default converts 
any ticker symbol you enter to use all capital letters.  This "Force Symbols to Upper Case" option is a 
requirement because Personal Stock Streamer needs to know exactly what symbol to look for when the data 
is returned by the quote server, so the symbol entered must exactly match the symbol returned by the quote 
server. 
 
Similarly, if a quote server requires that the ticker symbol is mixed-case, which for example can happen 
with different stock classes, you can disable the “Force Symbols to Upper Case” option so you can enter 
mixed-case ticker symbols such as BRKb or NOKa. 
 
There may be times when a particular ticker symbol is only available from a particular quote server.  Since 
Personal Stock Streamer has the ability to talk to different quote servers at the same time, you can override 
the quote server setting for any ticker symbol so that it is retrieved only from the server you choose. 
 
If you do not know the ticker symbol, the easiest way to locate the correct one is to use the Find Ticker 
Symbol command.  Since most of the supported quote servers include a ticker lookup feature, Personal 
Stock Streamer can take advantage of this to find your ticker symbols and add them to your portfolio or 
watch list. 
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• To search for a ticker symbol, select Portfolio->Find Ticker Symbol. 
• To disable the Force Symbols to Upper Case option, select Options->Preferences->General. 
• To tie a ticker symbol to a particular quote server, select Portfolio->Ticker Properties->Advanced. 

Arranging Ticker Symbols 
The most common way to arrange ticker symbols inside a portfolio or folder is to sort the entire portfolio 
on a specified column.  For example, if you wanted to have your portfolio sorted on the "% Change" field 
so that tickers are listed in descending order of their percent change for the day, you could click on the "% 
Change" column header.  An indicator arrow will appear in the header indicating the direction of the sort, 
ascending or descending.  If you want to reverse the order of the sort, click on the "% Change" column 
again.  The benefit of having your portfolio sorted this way is that the tickers are automatically re-sorted 
after a quote update so the sort order is always maintained. 
 
Another way to arrange ticker symbols and folders is by dragging and dropping them into place.  This 
works well if you want to move ticker symbols between different folders, or if you want to have a specific 
order for your symbols.  Note that dragging and dropping has the effect of turning off automatic sorting, so 
the tickers will not be re-sorted after quote updates. 
 
• To sort on a column, click on its column header.  To reverse the sort direction, click on it again. 
• To define secondary sort on a different column, right-click on its column header.  No indicator arrow 

will appear, but the sort will be in place. 
• To move a ticker symbol or folder, click and hold the mouse on it, then drag it into place.  To drag it 

below another folder without moving it inside the folder, hold the Ctrl key when you let go of the 
mouse button. 

• To move a ticker symbol or folder between portfolios or folders without affecting the sort order, select 
Portfolio->Move to.. and select the destination folder.  

Active vs. Inactive Tickers 
Since transactions are directly linked to their ticker symbols, when you delete a ticker symbol you also 
delete any associated transactions.  Since deleting transactions permanently affects your records, there 
needs to be a way to delete the symbol but keep all transactions that have been recorded for that ticker 
symbol.  The solution to this problem is the concept of active and inactive ticker symbols. 
 
When you create ticker symbols they are automatically active.  That is, they are displayed in all relevant 
views and they are updated normally along with the rest of the tickers. 
 
When you no longer want to track a ticker but you want to keep its transactions, you can mark the ticker 
inactive.  Inactive tickers are not updated automatically, not displayed in the Active Securities or News 
Headlines views, and they are only displayed in the Current Holdings view if there is an open position on 
them.  When the position is closed out the tickers disappears from all views, but the transactions are 
retained and can be viewed in the Transactions view. 
 
Note that inactive tickers are not deleted from the document, which means that if you mark a ticker inactive 
you can re-activate it at a later time.  To do this, first select View->Inactive Tickers to display all tickers 
that have been marked inactive, then use the Mark Active command to change them back to active tickers. 
 
• To delete a ticker symbol and its transactions, select Portfolio->Delete. 
• To mark a ticker or folder inactive, select Portfolio->Mark Inactive. 
• To mark a ticker or folder active, select Portfolio->Mark Active. 
• To view all inactive tickers and folders, select View->Inactive Tickers 

Changing (Renaming) a Ticker Symbol 
Sometimes a ticker symbol can change, such as when a company changes its name or gets listed on a 
different exchange.  Personal Stock Streamer does not automatically track ticker symbol changes, but you 
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should still change the ticker symbol in order for Personal Stock Streamer to be able to update quotes 
correctly.  Personal Stock Streamer provides a command explicitly for this purpose, and it ensures that all 
transactions that were posted to the old ticker symbol are properly retained under the new ticker symbol. 
 
• To change a ticker symbol, select Portfolio->Rename or press the F2 key. 

Asset Classes 
Asset classes are another way of organizing your ticker symbols.  They are basically categories, with names 
such as Stocks, Bonds, International Stocks, Large Cap Stocks, and so on.  Using asset classes is 
completely optional, but in some countries you may find it convenient to assign asset classes to your ticker 
symbols for reporting purposes. For stocks it is sufficient to assign a single asset class, but for mutual funds 
that consist of a mixture of different securities you can assign multiple asset classes on a percentage basis. 
 
As an example of the usefulness of asset classes, consider this example.  If you are limited to having only 
25% of your portfolio value in international investments, as long as you assign your international 
investments to the International asset class, you can run a report of value by asset class to make sure you 
are under the limit. 
 
• To assign an asset class to a ticker symbol, select the ticker symbol then select Portfolio->Ticker 

Properties.  The asset class assignment is under the General page. 

Currency Conversion 
If you are working with international investments, then the currency conversion feature in Personal Stock 
Streamer may be useful to you.  An international quote server will provide quotes in different currencies 
depending on the exchange where the ticker is listed.  For example, a stock on the London exchange may 
be quoted in British Pence while a stock on the Paris exchange may be quoted in French Francs.  If you are 
in Germany, you may want to have everything displayed for you in Deutsche Marks.  Personal Stock 
Streamer can be set up to do this conversion if the proper options are selected. 
 
The basic premise of doing currency conversion in Personal Stock Streamer is that everything is always 
converted from the quote currency (the currency in which the quote is retrieved) into the display 
currency.  The quote currency is set for each individual ticker symbol, while the display currency is set for 
all ticker symbols but can also be set for each portfolio, in which case the portfolio setting overrides the 
global setting.  No conversion is applied to any ticker symbol whose quote currency is not set. 
 
In the example given above, you would set the quote currency for the London stock to GBN (Pence) and 
the quote currency of the Paris stock to FRF (Francs).   Then you would set the display currency to DEM 
(Deutsche Marks) and Personal Stock Streamer would do the currency conversion automatically.  Don't 
forget to update the currency conversion ratios once in a while, since this is not done automatically in the 
current release. 
 
• To set the global display currency, select Options->Preferences->Display. 
• To set the display currency for a portfolio, select the portfolio, then select Portfolio->Portfolio 

Properties. 
• To set the quote currency for a ticker symbol, select Portfolio->Ticker Properties->Advanced. 
• To update the currency conversion ratios, select Online->Update Currency Table. 

Working with Transactions 
Transactions are the way the Personal Stock Streamer can keep you informed about the current value of 
your portfolio, as well as the way that past performance is tracked.  As we mentioned before, you should 
enter transactions after a trade is completed so that your position information is updated and any unrealized 
or realized gain can be calculated. 
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Personal Stock Streamer supports a range of transaction types that can be used to track your progress.  
These include not only the standard buy and sell transactions, but also transactions for dividend 
reinvestment, margin interest, and cashless stock transfers into and out of your accounts.  
 

Transaction Type Description 
Buy Normal purchase transaction or buy to cover for a short sale. 
Sell Normal sale transaction or short sale. 
Split Stock split or reverse split. 
Dividend Cash dividend; Can also be money market account dividend. 
Reinvest Div Dividend reinvested for stock. 
Transfer In Transfer of shares into the account from an outside source. 
Transfer Out Transfer of shares out of the account. 
MiscExpense Miscellaneous expense or account maintenance charges. 
MiscIncome Miscellaneous income. 
Deposit Cash deposit. 
Withdraw Cash withdrawal. 
Interest Cash interest. 
Margin Int Margin interest charges paid on a margin account balance. 
Return of Capital Return of Capital 

 
• To enter a transaction for a ticker symbol from the Active Securities, or Current Holdings view, select 

the ticker symbol then select Portfolio->Transactions->New Transaction. 
• To enter a transaction for an existing ticker symbol from the Transactions view, select a previous 

transaction for that ticker symbol then select Portfolio->Transactions->New Transaction. 
 
A word of caution: Because transactions are linked to their ticker symbols, you should be careful when 
entering new transactions from the Transactions view without first selecting from the list the ticker symbol 
itself or a previous transaction for that ticker symbol.  If you do not do this, the transaction entry dialog will 
leave the Symbol field blank, allowing you to fill it in by hand.  However even if you fill in the Symbol 
field to be the same as an existing ticker symbol, Personal Stock Streamer does not know that you want to 
associate the new transaction with the existing ticker symbol.  In this case it will create another instance of 
the ticker symbol which is completely independent of the existing instance. 
 
An example of when this is a problem is if you have an existing ticker symbol with a Buy transaction and 
you want to close out your position.  If you don't associate the Sell transaction with the correct ticker 
symbol (ie. if the Buy and Sell transactions are posted to different instances of the same ticker symbol) then 
the Gain will never be calculated and the ticker symbol will continue to be listed in the Current Holdings 
view. 
 
If you do get into trouble and have transactions spread between multiple instances of a ticker symbol, you 
can correct it by moving all of the transactions under one ticker symbol using transaction cut and paste.  
Then you will be free to delete the extra instances of the ticker symbol. 
 
• To cut a transaction from a ticker symbol to the clipboard, select the ticker symbol then select 

Portfolio->Ticker Properties->Transactions, then select the transaction and press the Cut button. 
• To paste a transaction from the clipboard, select the ticker symbol then select Portfolio->Ticker 

Properties->Transactions, then press the Paste button. 

Partial Sales with Multiple Lots 
By default, Personal Stock Streamer calculates proceeds from sales in FIFO order.  This means that if you 
hold multiple lots of a stock and you sell some shares, the software will calculate the gain on the 
assumption that you sold the first lot first, the second lot second, and so on.  Since this is sometimes not 
what really happens, you can indicate to Personal Stock Streamer the order in which it should calculate 
gains by using the Select Lots button in the transaction entry dialog when you are entering the sale.  This 
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button will allow you to select lots in the order in which they should be applied to the sale, so that your gain 
and remaining shares are properly calculated. 

Transaction Currency 
Personal Stock Streamer allows you to specify the currency and conversion ratio for individual transactions 
on the date of the transaction in order to maintain an accurate representation of your portfolio.  If you are 
using the currency conversion function, you should make sure to select the appropriate currency and enter 
the conversion ratio from your brokerage statement.  If you do not enter this information, currency 
conversion will be done at the current conversion rate, which will cause the transaction value to fluctuate 
whenever you update the currency table. 

Selling Short 
Personal Stock Streamer does not include an explicit Sell Short transaction type.  Instead, any Sell 
transaction that is made when you do not have a long position on a stock is considered a short transaction.  
Therefore to enter a short sale you would make a normal Sell transaction for the appropriate number of 
shares.  In the Securities and Holdings views, a short position will be indicated when the number of shares 
listed in the Shares column is negative. 
 
To cover a short transaction, enter a normal Buy transaction for that ticker.   Personal Stock Streamer will 
recognize that this is a buy to cover, and will calculate the gain appropriately at that time. 

Stock Splits 
Personal Stock Streamer handles splits like any other transaction.  Splits are not detected automatically by 
the software, so if you are watching or holding a stock that splits then you should enter the split transaction 
on the date that the stock starts trading at the split price.  Entering a split transaction will also ensure that 
your current holdings are adjusted appropriately so that the number of shares and basis are correct for the 
gain calculations.  For example a 2-for-1 split would be entered as a Split transaction with 2 in the New 
Shares box and 1 in the Old Shares box. 
 
The only tricky part of handling splits is what to do when you have more than one instance of a particular 
ticker symbol.  In this case you have to enter the split transaction for each ticker that has current holdings.  

Reverse Splits 
Sometime a company will issue a reverse split for a particular reason, such as to increase its share price. 
Reverse split transactions in Personal Stock Streamer are entered the same way as regular split transactions, 
but you just have to make sure that you put the correct numbers in the New Shares and Old Shares boxes.  
For example, a company issuing a 1-for-10 reverse split (for every 10 shares you currently own, you will 
own only one share after the split) would be entered as a Split transaction with a 1 in the New Shares box 
and a 10 in the Old Shares box. 

Creating Accounts 
If you want to track your current holdings and the value of your portfolio, you can create the entries to 
reflect your accounts and investments.  The basic procedure is to create account folders for each of your 
accounts, create cash symbols to represent your uninvested balance, create the appropriate ticker symbols 
in each account, and then enter transaction histories.  If you have transaction histories in a program such as 
Quicken that can export transactions to a QIF file, Personal Stock Streamer can import those files to save 
you time entering transactions. 
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The benefit of creating accounts is that you can track your portfolio value and gains fairly easily.  Personal 
Stock Streamer will display unrealized gains in the Gain column when you are in the Active Securities 
view, and realized gains in the Gain column when you are in the Transactions view.  The current value is 
displayed in the Total Value column.  The total under the Change column is the net change in value of your 
account for the current day, based on the Change value and the number of shares of each item. 
 
• To create an account, select Portfolio->New->Folder/Account. 
• To create a cash symbol, select Portfolio->New->Cash Symbol. 
• To create a ticker symbol, select Portfolio->New->Ticker Symbol. 
• To enter a transaction, select the symbol, then select Portfolio->Transactions->New Transaction. 
• To display the complete transaction register, select View->Transactions. 
• To display the securities list after displaying the transaction register, select View->Securities. 
• To import a QIF file, select File->Import, and select QIF as the file type. 

Adjusting the Cash Balance 
When you create a linked cash symbol in an account, it may not be immediately obvious how the cash 
balance is calculated.  Recall that linked cash symbols reflect the transactions posted to the ticker symbols 
in the same folder and subfolders, so even if you create a cash symbol with a zero balance it will have a 
balance based on the transactions for other ticker symbols in that folder. 
 
For example, say you have a folder in which you created a ticker symbol IBM and purchased 100 shares at 
100 dollars each (and no commission), for a total cost of 10,000.  If you later create a linked cash symbol in 
that folder with a zero balance, its balance will automatically be recalculated to be -10,000 because of  the 
IBM purchase transaction.  If the real cash balance in that account is 2,000, then you will need to enter an 
adjustment deposit of 12,000 in order for the balance to be correct.  However from that point on the balance 
should always match your statements as long as you properly enter all transactions posted to that account. 

Working with Charts 
Personal Stock Streamer includes an advanced charting package with technical analysis.  You can have 
multiple charts open at the same time, and you can have multiple profiles with multiple technical indicators 
and switch among them at will. 
  
• To display a chart, select the ticker, then select Portfolio->Chart->Intraday or Historical. 
• To display charts for several tickers at once, hold down the Ctrl key while clicking on the additional 

symbols, then select the Intraday or Historical command. 
 
You can link charts using the Link option.  This means that when you change the ticker symbol in one chart 
it changes in all of the linked charts.  This way if you have different profiles or chart types selected in the 
different charts, all of the charts will update at once. 
 
To create or edit chart profiles, to add or change indicators or parameters, use the Edit button under the 
chart.  This will display the dialog that will allow you to change the chart settings.  In this dialog you can 
also change the appearance of the main chart, including setting the chart type and changing the Y axis 
between log and linear. 

Zooming 
Personal Stock Streamer charts provide a zooming capability that lets you focus on a particular range of 
dates or times.   Historical charts can be zoomed down to a single day, and intraday charts can be zoomed 
down to a one hour. 
 
To begin the zoom, hold down the Ctrl key on the keyboard and click the mouse at the location on the chart 
where you want to start the zoom.  While holding down the mouse button, move the mouse to the location 
on the chart where you want to end the zoom.  This will highlight the segment of the chart that will be 
zoomed.  When you release the mouse button, the chart will be zoomed to that segment and the Duration 
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box will be set to Custom.  You can also zoom in further on any segment of a zoomed chart.  To un-zoom 
the chart, right-click inside the chart and select Un-Zoom, or select a different duration from the Duration 
box. 

Line Drawing 
Personal Stock Streamer charts support line drawing and Fibonacci retracements that allow you to get a 
better analysis of trends.  To draw a line on the chart, click on the location where you want to begin the line 
and while holding down the mouse button move the mouse to the location where you want to end the line.  
When you release the mouse button the line will be drawn.  To set Fibonacci retracements, right-click on 
the line and select the Fibonacci retracements option. 

Additional Options 
There are several options available in the chart under its context (right-click) menu that are not available in 
the top-level menus.  These include Remove High and Low Ticks, and Close All Charts.  To see all of the 
options and available commands, click the right mouse button inside the chart. 

Custom Indicators 
Starting with Personal Stock Streamer 7.0, you can create custom indicators using Personal Stock Streamer 
extensions.  For more information see the chapter on integration with other software later in this guide. 

Setting Alerts 
Personal Stock Streamer includes one of the most powerful alert systems on the market.  It will keep you 
informed of important events on ticker symbols in any portfolio or folder based on criteria you choose.  
Alerts can be set on a number of fields, including Price, Bid, Ask, Change, Volume, and others.  The alert 
function is flexible, too: You can set as many alerts for each ticker symbol or folder as you want, and each 
alert can trigger a different action. 

Alert Types 
Alerts consist of two parts: a condition and an action.  A condition is a mathematical expression such as 
"Price > 24.25" which is tested after each quote update.  When the expression evaluates to true or a non-
zero value, the associated action is triggered.  The only exception to this is the News alert, which is defined 
as a Boolean condition which evaluates to true when there is new news available.  Personal Stock Streamer 
includes a selection of possible actions that can be taken as a result of a condition being met: 
 
 

Action Description 
None Indicate that an alert was triggered with a yellow bell next to the alert 

attribute. 
Beep Speaker Play the standard system beep. 
Flash Window Flash the toolbar button and/or task bar icon if the main program window is 

not in focus. 
Bring to Top Bring the main program window to the foreground if it is minimized or 

obscured by other windows. 
Play Sound Play a sound, which must be a .wav file. 
Set Color Change the cell color. 
Run Program Run another program. 
Send Email Send an email message containing the alert information. 
Send to 
NotePager Pro 

Send the alert to a running copy of NotePager Pro software, which allows 
advanced paging, email and SMS messaging.  For more information visit 
http://www.notepager.com. 

Run Script 
Function 

Runs the named script function, with an optional parameter.  The script 
function can come from any of the currently loaded scripts or extensions. 
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When an alert is set on a field such as Price, a little black bell will appear next to the Price field for that 
ticker symbol.  (You can prevent it from appearing by changing the Alert Set Indicators option under 
Options->Preferences->Display.)  When the alert is triggered, a yellow bell will appear next to the field, 
and a yellow alert triangle will appear in the first column on the screen.  This ensures that even if you set an 
alert on a field that is currently not visible, you will still see that there is an alert present by the yellow 
triangle next to the symbol. 

Setting Alerts 
One thing to note with regard to alerts is that external alerts (run program, email, and pager) will not work 
unless the Suspend External Alerts option is turned off under the Options menu.  This option is there to 
easily allow you to suspend these alerts while you are at your desk but resume them when you go away. 
 
• To configure pager or email settings, select Options->Preferences->Services. 
• To create alerts on ticker symbols, select the symbol, then select Portfolio->Ticker Properties->Alerts. 
• To create alerts on folders, select the folder, then select Portfolio->Folder Properties->Alerts.   
• To create alerts on portfolios, select the symbol, then select Portfolio->Portfolio Properties->Alerts.  
• To create alert conditions on ticker symbols, select the symbol, then select Portfolio->Ticker 

Properties->Alerts. 
• To create alert actions, select Portfolio->Alerts->Edit Alert Actions, or press the "…" button while 

editing the alert. 
• To enable or disable the Suspend External Alerts option, select the Options menu. 
 
There is one important thing to be aware of when you define folder and portfolio alerts:  Folder and 
portfolio alerts are never actually triggered for the folder or portfolio itself.  What happens when you define 
this type of alert is that each ticker symbol is tested for the alert condition, and when the condition is met 
the alert is copied into the ticker symbol and triggered.  What this means is that if you look at the alert list 
for that ticker symbol, you will see a copy of the alert from the folder or portfolio as if it was defined for 
the ticker symbol all along.  Alerts that are copied this way are shown in the list in gray instead of black to 
differentiate them from the regular alerts defined on that ticker.  These copied alerts will be automatically 
deleted from the list when you reset the alert by selecting the Clear Alerts command as described below, 
but you can also manually delete them if you like. 

Alert Expressions 
Personal Stock Streamer includes support for free-form alert expressions which allow you to specify even 
more powerful alert conditions which can include multiple fields and values.  Expression alerts can also use 
Boolean operators and functions. 
 
• To create alert conditions using free-form expressions, then select the Free-form Expression box when 

editing the alert condition. 
• The field names in the expression must be exactly the same as the names on the columns, including 

capitalization, and they must be entered in quotes.  For example, if you want to use the Price field in an 
expression, you must enter it as “Price”, because “price” will not work.  The only exception is field 
with spaces, in which case the spaces are optional so for example “% Change” can also be entered as 
“%Change” and “52 Week High” can also be entered as “52WeekHigh”. 
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The following are valid operators and types for expressions: 
 

Operator Description 
<, >, <=, >=, == Standard comparison operators: less than, greater than, 

less than or equals, greater than or equals, exactly 
equals. 

&&, || Boolean AND and OR operators 
(, ) Paretheses are used to control order of evaluation by 

creating sub-expressions. 
abs() Function that returns the absolute value of its argument 
+, -, /, * Standard mathematical operators: add, subtract, divide, 

multiply. 
 
Some examples: 
• Price of your stock goes up by more than 10% and the volume is more than ten million shares: 

("%Change" > 10) && ("Volume" > 1000000) 
• Price of your stock goes up by more than 10% or your unrealized gain is more than 50%: ("%Change" 

> 10) || ("%Gain" > 50) 
• Price of your stock goes up or down by more than 10%: abs("%Change") > 10 

Clearing Alerts 
When an alert is triggered it must be cleared before it can be triggered again.  The only exception to this is 
a news alert, which is always triggered on any new headlines.  Clearing the alert indicates to Personal Stock 
Streamer that you have received it, which is especially important for alerts which you have set to repeat 
periodically because it is the only way to stop the repetition. 
 
• To clear a single alert, select the ticker then select Portfolio->Alerts->Clear Alert. 
• To clear all alerts for all tickers, select Portfolio->Alerts->Clear All Alerts. 
 
5. The Ticker Bar 
 
The ticker bar is a special window that continually scrolls quotes and news across your screen, just like on 
TV!  With the ticker bar, you can keep an eye on everything while doing other work, because the ticker bar 
window stays on your screen as long as Personal Stock Streamer is running. 
 
While the ticker bar is running, different colors represent different events such as positive change, negative 
change, and if an alert is active for the ticker symbol.  You can even get detailed information on any ticker 
that scrolls by with one or two clicks. 
  
• To display the ticker bar, select View->Ticker Bar. 
• To change ticker bar preferences, select Options->Preferences->Ticker Bar. 
• To get information on a ticker, move the mouse so that the ticker is outlined, then click the left mouse 

button to display ticker properties, or click the right mouse button for additional options such as news. 
• To manually scroll the ticker bar right or left, hold down the Ctrl key while clicking inside the ticker 

bar, then move the mouse right or left. 
• To drag the ticker bar to a different location, hold down the Alt key while clicking inside the ticker bar, 

then drag the window to the desired location. 
 
6. News Headlines 
 
The RSS News Headlines window allows you to keep track of multiple “feeds”, or news sources.  The 
news headlines module supports most RSS and Atom feeds available on the Internet, including news and 
blogs, and updates the headlines automatically while Personal Stock Streamer is online.  Most feeds are 
available completely free of charge, although premium feeds (such as The Wall Street Journal) may charge 
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for access to the full article bodies.  When new headlines arrive, the main Personal Stock Streamer will 
show the number of unread articles in the status bar at the bottom of the window. 
 
• To display the RSS News Headlines window, select Tools->RSS News Headlines. 
 
The news headlines window consists of a left and right pane, with the right pane split into upper and lower 
halves.  The left pane displays a tree showing the current feed subscriptions, and the right pane shows the 
list of articles in the upper part and the currently selected article in the lower part. 

Adding new Feeds 
To add feeds manually, press the add new feed button in the toolbar or right-click on the location in the 
feeds panel where you want to add the feed and select the “Add new feed” option. 
 
Personal Stock Streamer supports drag-and-drop creation of news feeds.  For example, if you are browsing 
a web site with an RSS feed and want to add that feed to the news headlines window, simply drag the feed 
URL from your web browser into the RSS News Headlines window, and the feed will be added to your list. 
 
The RSS Headlines window also directly supports the per-ticker RSS feeds provided by Yahoo Finance.  
To create a news feed for a particular stock ticker, drag the ticker from your portfolio into the RSS News 
Headlines window. 
 
You can create folders to group feeds using the right-click context menu in the feed pane, and you can drag 
and drop feeds to arrange them into folders. 

Reading the Articles 
To read a news feed, select it from the list of feeds in the left pane.  The current list of articles will be 
displayed in the top right pane, and you can read the articles by clicking on the headline in that pane. 
 
Most RSS feeds do not actually include the article body.  They often have no text or just a short summary, 
so a link is provided to the full article.  To read the full article in your web browser, you can click on the 
link or double-click on the article headlines form the list. 
 
• To change how many articles are displayed in the article list, select the desired time period from the 

drop-down list in the toolbar. 
• To go to the next unread article in the current feed, press the Next Unread Article button in the toolbar 

or press the “N” key on your keyboard.  If the next unread article is in a different feed than the one 
currently selected, that feed will be selected. 

• To “catch up” and mark all articles in the currently selected feed as read, right-click on the feed and 
select “Mark All Articles as Read” from the menu, the “Mark All Read” in the tool bar, or press the 
Ctrl, Shift, and “C” keys simultaneously. 

• To mark an article unread, press the “M” key. 
• To create a ticker bookmark for an article, drag the article headline from the headline window to the 

desired ticker in the Active Securities view. 

Import/Export 
You can also import and export lists of feeds in the common OPML format supported by many RSS 
applications and aggregators.  The Import OPML and Export OPML commands are available under the 
Options menu in the RSS News Headlines window. 
 
7. Researching your Investments 
 
There is a wealth of research information available on the Internet, so much so that the biggest problem is 
keeping track of it all.  Personal Stock Streamer has several ways to help you keep track of what you find 
so that you have it when you need to refer to it later. 

 25



Bookmarks 
Personal Stock Streamer includes a bookmarks (or "favorites") feature that allows you to keep track of 
important web sites.  The software comes preloaded with a selection of sites from quote server web sites to 
research and other informational sites.  These bookmarks are available at all times within the program, and 
you can easily edit this list as you wish to add your own sites. 
 
One interesting trick for fast access of bookmarks is to use mnemonic key assignments.  When you create 
the bookmark, you can indicate that you want quick access to that bookmark from a particular key by 
putting an ampersand (&) before that letter.  For example, if there was a bookmark that was called “Motley 
Fool” and you wanted quick access to it through the "F" key, you would create the bookmark as "Motley 
&Fool".  When you select the bookmark menu that contains this bookmark, the "F" will be underlined and 
you can quickly select the "Motley Fool" bookmark by pressing the "F" key when that menu is displayed.  
This can save you a little work because for lists with many bookmarks you no longer have to scroll down to 
the correct bookmark with your mouse.  This key assignment trick also works for ticker bookmarks and 
jump points as described below. 
 
• To jump to a bookmark location (URL), select the bookmark from the Online->Bookmarks menu, or 

from the bookmarks pop-up window. 
• To bring up the bookmarks pop-up window or to edit the bookmarks list, select Online->Bookmarks-

>Edit Bookmarks. 

Ticker Bookmarks 

Ticker bookmarks are special bookmarks that are stored for a particular symbol instead of globally for the 
entire program.  The reason this feature is so useful is that it allows you to store specific links to news or 
articles for a particular symbol without cluttering the bookmark list.  You can then recall these items at any 
time with just a couple clicks. 
 
• To jump to a ticker bookmark, right-click on the ticker symbol, then select Ticker Bookmarks, then 

select your desired bookmark.  You can also jump to a bookmark by selecting Portfolio->Ticker 
Bookmarks, and the bookmark after selecting the symbol. 

• To edit ticker bookmarks, select the ticker symbol then select Portfolio->Ticker Properties-
>Bookmarks. 

Jump Points 

Jump Points are special global bookmarks that allow you to substitute the ticker symbol or name for part of 
the bookmark.  This allows you to create a single bookmark that will be valid for all ticker symbols, such as 
a link to a chat room or a research site where the only parameter you need is the ticker symbol or name.  
This eliminates the need to create special bookmarks for each ticker symbol. 
 
Jump Points are contained in the global bookmark list under a special folder called Jump Points. Although 
you can call your own Jump Points whatever you like, you must not rename the Jump Points folder or else 
it will lose its special properties and will not be recognized properly by the software.  Of course if you ever 
rename it by mistake you can always change the name back to Jump Points and everything will return to 
normal. 
 
You can create your own Jump Points by putting a special tag into the location or URL of the bookmark.  
When you later select the Jump Point, Personal Stock Streamer will substitute the tag with the correct item 
from the ticker symbol before passing the URL to your browser.  The valid tags that are currently available 
are listed in the table below. 
 

Tag Description 
$(Symbol) Full ticker symbol. 
$(Symbol[0]) The first character of the ticker symbol. 
$(Name) The name of the ticker symbol. 
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For example, to go to the Yahoo quote page for a particular symbol, create a jump point as 
http://finance.yahoo.com/q?s=$(Symbol)&d=t.  When this Jump Point is selected Personal Stock Streamer 
will substitute the ticker symbol for the $(Symbol) tag and take you to the correct quote page. 
 
• To jump through a Jump Point, select the ticker symbol then select the appropriate Jump Point from 

the Online->Bookmarks->Jump Points menu, the bookmarks list, or the right-click menu. 
• To edit the Jump Point list, select Online->Bookmarks->Edit Bookmarks to bring up the Bookmarks 

window and edit the bookmarks in the Jump Points folder. 

Drag and Drop Bookmarks 

Drag and drop is widespread in the implementation of the Bookmarks system, and is designed to make 
creating and managing bookmarks quite easy.  The following drag and drop operations are supported: 
 
• You can drop bookmarks into the Bookmarks window or on top of a ticker symbol.  In the latter case 

the bookmarks will become a ticker bookmark and will be stored with the ticker symbol. 
• Drag and drop bookmarks from Internet Explorer 3.02 or later or Netscape 4.0 or later. 
• Drag links from any OLE-compatible application.  Even if you happen to be in a Word document that 

has a piece of text such as http://www.something.com in it, you can highlight that text and drag that 
text into the Bookmarks window or into a ticker symbol to create a bookmark. 

• Drag headlines from the News Headlines view in Personal Stock Streamer to a ticker symbol, browser 
window, or another OLE-compatible application. 

• In the embedded browser window in Personal Stock Streamer, you can drag a link from within the 
browser window to create a bookmark for that link, or you can drag the little bookmark icon next to the 
URL to create a bookmark for the current page. 

 
8. Reports 
 
Personal Stock Streamer includes a report view that allows you to get a summary of things like capital 
gains over the course of a year or a list of transactions between two dates.  Reports are always displayed for 
the currently selected portfolio. 
 
• To select the Reports view, select View->Reports. 
 
When you select the Reports view, a filter bar will appear which will allow you to select the report type and 
date range.  The screen is automatically updated when you change the filter. 
 

Next to the report type drop-down, there is a Report Properties button ( ) which can be used to change 
any additional settings for the report.  Not all reports will have additional settings, so this button will only 
be enabled when supported by the selected report. 

Custom Reports 
Starting with Personal Stock Streamer 7.0, you can create custom reports using Personal Stock Streamer 
extensions.  For more information see the chapter on integration with other software later in this guide. 
 
9. Importing and Exporting Data 
 
Personal Stock Streamer can import and export several types of ASCII-format data, including QIF and 
Metastock ASCII format. 
 
The simplest format for importing and exporting is known as the comma-delimited or comma-separated 
value (CSV) format.  CSV files contain lists of items such as ticker symbols and prices separated by 
commas.  For example: 
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 MSFT,90.0,50.0,70.0 
 
You may also have a longer CSV file that just contains a list of ticker symbols you wish to import: 
 MSFT 
 DELL 
 IBM 
 AOL 
 RHAT 
 
Personal Stock Streamer can easily import this list to create ticker symbols in the current portfolio. 
 
You can also export your current data to a variety of formats (including CSV) for exchange with other 
software or for use in your spreadsheets. 
 
• To import a text file, select File->Import. 
• To export a text file, select File->Export. 
 
There are also several special formats supported by Personal Stock Streamer which help you exchange data 
with programs such as Quicken and Metastock. 

Importing from Quicken 
You can export your transactions from Quicken as a QIF file (select File->Export in Quicken) then use the 
File->Import command in Personal Stock Streamer to import the portfolio data.  This procedure will work 
with most other software that exports QIF files, such as Microsoft Money. 
• If you are starting with a blank portfolio in Personal Stock Streamer, you should first create a file that 

contains your list of securities by checking the Security Lists option in the Quicken export dialog, and 
importing this file into Personal Stock Streamer.  

• To export the transactions from Quicken, select the Transactions option in the Quicken export dialog. 
• To import a QIF file into Personal Stock Streamer, select File->Import and select the QIF option in the 

Files of Type field. 

Exporting to Quicken 
To export a QIF file from Personal Stock Streamer, first select View->Transactions.  If you wish to only 
export a subset of transactions, select the transactions you wish to export.  Then select File->Export, and 
make sure that QIF is the type selected in the Files of Type field.  Enter the file name and press OK to 
export. 
 
The exported QIF files can also be imported into most software that supports the QIF standard, such as 
Microsoft Money. 

Exporting to Metastock 
Metastock is one of the most widely used technical analysis programs available, and the Metastock ASCII 
data format has become a de-facto supported standard among other technical analysis programs as well. 
Personal Stock Streamer supports exporting current and historical data to this format so that you can use the 
data for your analysis. 
 
• To export current or historical data in Metastock format, select the ticker symbols for which you wish 

to export data, then select File->Export and select one of the Metastock options, then enter the file 
name and press Save. 
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Exporting Transactions to CSV 
For those of you who still use a program such as Excel for analysis or reporting, you can export a list of 
transactions to a comma separated value (CSV) file.  Importing transactions from a CSV file is currently 
not supported. 
 
• To export transactions to a CSV file, select View->Transactions, select the transactions you wish to 

export, then select File->Export.  Make sure to select the CSV option in the Save as Type field before 
pressing the Save button. 

 
10. Integration with Other Software 

Plug-Ins 
Among the many features that Personal Stock Streamer already offers, you can add even more functionality 
through Personal Stock Streamer plug-ins.  These plug-ins are similar to those you may see for your web 
browser: they provide specific enhancements to the existing software or add support for additional features.  
Personal Stock Streamer provides an open architecture that allows developers to write a wide variety of 
plug-ins in order to meet your changing needs. 
 
Plug-ins may be downloaded directly from the developer's web site, the DTLink web site, and some 
developers may choose to make their plug-ins available through the Software Update Wizard.  Plug-ins 
downloaded through the Software Update Wizard may be installed automatically, but plug-ins downloaded 
directly from the developer's web site must be installed by going through the plug-in management page 
inside Personal Stock Streamer. 
 
• To install, uninstall, or configure plug-ins, select Options->Preferences->Plug-ins. 
• For a list of currently available plug-ins, visit our web site at http://www.personalstockstreamer.com. 
 
DTLink Software offers a Software Development Kit (SDK) for developers interested in writing plug-ins 
for Personal Stock Streamer.  For additional information, visit our web site at 
http://www.personalstockstreamer.com. 

Extensions 
Plug-is are one way to extend Personal Stock Streamer functionality, but they require fairly advanced 
software development skills as well as a compiler and other developer tools.  For the majority of our 
customers that is simply not practical, so starting with Personal Stock Streamer 7.0 we created a special 
plug-in that allows you to develop your own extensions using simple scripting languages such as VBScript 
and JScript.  No development environment is required since extensions may be created with a simple text 
editor such as Notepad.  With this new extension interface, you can easily access all of your portfolio data 
from other applications such as Excel (using VBA in this case) in a way far superior to the simple DDE 
interface described below. 
 
With extensions you can create custom indicators and reports, make calculations, generate alerts, display 
forms to get information, and more.  Extensions are installed and managed through the Extensions 
command under the Tools menu.  This command displays a dialog that lets you install, remove, and update 
extensions.  When an extension is installed, Personal Stock Streamer remembers where it was installed 
from so that it can be easily updated. 
 
Extensions may also be digitally signed to verify their authenticity.  Because of the large number of things 
that extension scripts can do, you should only install extensions from sources you trust. 
 
Additional information, articles, and sample code for developing extensions is available on the Personal 
Stock Streamer web site at http://www.personalstockstreamer.com . 
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Dynamic Data Exchange (DDE) 
DDE is a way of dynamically linking different applications and allowing them to exchange data and 
commands.  Personal Stock Streamer includes a plug-in that implements DDE to allow dynamic linking of 
Personal Stock Streamer to client applications such as Microsoft Excel.  When a link is established, data is 
automatically updated in the client application whenever it is updated in Personal Stock Streamer. 
 
For applications such as Microsoft Excel, you can establish a dynamic link to one or more ticker symbols 
simply by dragging and dropping the desired symbols from Personal Stock Streamer into your Excel 
spreadsheet.  Exactly which fields are linked can be configured in the program preferences. 
  
• To configure DDE, select Options->Preferences->Data Exchange. 
 
Personal Stock Streamer is pre-configured for Microsoft Excel and Corel Quattro Pro, but you can also 
enter a custom syntax for other applications. 
 
Note: For applications such as Excel and Quattro Pro, some parts of the DDE link have to be put in quotes 
or apostrophes for them to work properly.  Therefore you will need to make sure that the names of 
portfolios and folders that contain the tickers you are dragging do not have any quotes or apostrophes. 

Topic and Item Syntax 
If your client application does not accept drag and drop, you can manually establish DDE connections by 
entering the appropriate connection string into your application. 
 
DDE syntax normally consists of three parts: a server, a topic, and an item.  These are often expressed as 
server |topic!item.  To clarify, this is the DDE server name, followed by a vertical bar, followed by the 
topic, followed by an exclamation point, and finally followed by the item.  However different applications 
have different ways of expressing DDE links, so you should check the help for your particular application 
to determine the exact syntax. 
 
For Personal Stock Streamer, the server name is “PSM”.  In the general case, the topic is the ticker symbol 
and the item is the name of the field (such as Price, % Change, or Volume).  The exceptions for the topic 
syntax occur when you have multiple identical ticker symbols within your document.  Although you can 
specify just the ticker symbol as the topic, Personal Stock Streamer will link to the first one it finds, so in 
order to link to a specific ticker symbol in a particular portfolio or folder, you have to specify the full 
“path” of the ticker symbol. 
 
The ticker “path” consists of a series of portfolio and folder names, separated by backslashes, that tell 
Personal Stock Streamer exactly which ticker you are referring to.  If the path contains any spaces or non-
letter characters, you may have to surround the entire path with single or double quotes (again this depends 
on your application).  For our example example we will use Microsoft Excel, which requires single quotes.  
So if you have a ticker YHOO in a subfolder called Internet in a folder called Watch List in a portfolio 
called My Portfolio, the full path of the ticker would be ‘My Portfolio\Watch List\Internet\YHOO’.  This 
single-quote rule also applies to fields such as ‘% Change’. 
 
Given the example above, the full DDE syntax to access the %Change field is as follows: 
 PSM|’My Portfolio\Watch List\Internet\YHOO’!’% Change’ 

The System Topic 
Some DDE clients support use of what is known as a System topic, which allows the client to enumerate 
the available topics and items in order to allow you to select them from a list.  Although Personal Stock 
Streamer does support the System topic, it is very limited in function.  Because Personal Stock Streamer is 
a dynamic system, the topic and item lists are not pre-generated and therefore can not be fully enumerated 
by clients.  What will happen is that the System topic will only allow you to enumerate those topics and 
items to which you have already established links, therefore for those DDE clients that support this 
function, you will not be able to browse all available topics and items ahead of time. 
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Excel DDE Syntax 
The DDE syntax for Excel is a formula with the format “=server|topic!item”, following the topic and item 
syntax above.  Constructing and placing this formula in a cell will establish the connection to a running 
copy of Personal Stock Streamer. 
 
The file Sample Portfolio.xls (included with Personal Stock Streamer) contains an example of linking to the 
Sample Portfolio.stk file.  For additional help on creating DDE links in Excel, see the DDE topic in the 
Excel on-line help. 
  
11. Getting Help 
 
Finally, if you have trouble figuring out what a dialog or menu item does, there are a couple of things you 
can do.  Personal Stock Streamer includes a full context-sensitive online help system which explains all of 
the dialogs and commands. 
 
• If you need help on a dialog, you can press the Help button or F1, which will bring up the online help. 
• If you need help on a menu item, highlight the menu item then press F1. 
• To bring up the help contents, select Help->Help Contents. 
 
We also offer Web and email support to our customers through our Web site at 
http://www.personalstockstreamer.com. 
 
• To contact Technical Support by email, select Help->Technical Support->Contact Technical Support. 
 
Thanks for using Personal Stock Streamer! 
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A. Column and Field Reference 
 
Personal Stock Streamer can only display the fields that are available from the quote server or can be 
calculated from the available data.  Please keep in mind that many quote servers do not provide data for all 
fields even though Personal Stock Streamer allows their display.  When a field is not available at the quote 
server, it will be displayed with a zero or blank value on the screen. 
 
For the "Active Securities" and "Current Holdings" views: 
 

Symbol The ticker symbol 
Type The type of ticker symbol (Stock, Mutual Fund, Option, Money Market, Index, 

Bond, Future, Commodity) 
Name The long name of the ticker symbol, could be company name or description 
Price Last quoted price 
Change Change in price from previous close. 

Note: The total under the Change column is the same as the total for the Value 
Change column.  This is just a quick way of seeing the change in value if you 
don't want to see the Value Change column all of the time. 

High High price for the day 
Low Low price for the day 
Volume Number of shares traded 
Last Update Date and time this quote was last updated by PSM, in local time 
Open Price of ticker at market open 
Open Int. Open Interest, only applicable for options 
Avg. Vol Average volume 
Bid Price a market maker is willing to pay for one share  
Ask Price at which a market maker is willing to sell one share 
Spread Difference between Bid and Ask 
Bid x Ask Size of Bid and Ask 
Prev Close Price of ticker at close of market the previous day 
52 Week High Highest closing price over the past year 
52 Week Low Lowest closing price over the past year 
Last Trade Time of last recorded trade 
Last Size Size of last recorded trade 
Exchange Exchange on which this ticker trades 
P/E Ratio Price to earnings ratio 
EPS Reported Earnings Per Shares 
Dividend Annual dividend 
Yield Yield 
Beta Relative volatility. 
Mkt. Cap Market Capitalization 
Shares Number of shares currently held in portfolio 
Avg. Basis Average price paid for the shares held, excluding commissions 
Avg. Cost Average price paid for the shares held, including commissions 
Total Basis Total price paid for the shares held, excluding commissions 
Total Comm. Total commissions paid for the shares held 
Total Cost Total price paid for the shares held, including commissions 
Share Value Current value of shares determined by price (or bid/ask if that option is 

selected) multiplied by number of shares.  This column will not be filled in for 
cash symbols. 

Total Value Same as share value, except value of cash symbols will be included. 
Value Change Net change in value for the current day. 
Gain Current unrealized gain, the difference between the share value and total cost.  

Note that this does not include the anticipated commission to be incurred for 
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closing out the position. 
Avg. Age Average age (in months) of the shares held. 
Currency Currency in which this ticker is quoted at the quote server. 
Server Quote server selected for this ticker.  If "Default" then the global setting is used. 

 
For the "Transactions" view: 
 

Type Type of transaction 
Avg./Share Average cost per share 
Gain Realized gain for the transaction 
Total Total value of transaction 
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